Paint bucket not working

Please use this part to report bugs & errors, ask questions & "How to..."
Post Reply
Elena C
Posts: 6
Joined: 19 Aug 2017, 08:40

Paint bucket not working

Post by Elena C » 02 Nov 2017, 16:26

Hello,
I am trying to color an animation and I have followed exactly the steps shown in your tutorial. However the bucket tool does not fill inside my character but outside of it. What am I doing wrong?
Also:
I've tried using the rectangle fill tool and although it does the job, it thickens the lines that are not meant to be shape contour (like the hairs of my character). Please look at the attached images to see what I mean.

This is so frustrating :( I would really appreciate your help!

P.S. I just noticed that the bucket stops working properly after I switch to a different tool and come back.
Attachments
Screen Shot 2017-11-02 at 18.12.13.png
Screen Shot 2017-11-02 at 18.12.13.png (76.83 KiB) Viewed 153 times
Screen Shot 2017-11-02 at 18.12.03.png
Screen Shot 2017-11-02 at 18.07.11.png
Screen Shot 2017-11-02 at 18.06.38.png

User avatar
Elodie
Site Admin
Posts: 13298
Joined: 06 Jan 2009, 09:53
Location: Metz

Re: Paint bucket not working

Post by Elodie » 02 Nov 2017, 16:52

Weird. have you tried to reset the paint bucket ?
Questions or problems regarding the forum ? Please contact me by PM
Question regarding TVPaint or need a quotation ? Please contact me by email

User avatar
Fabrice
Posts: 9749
Joined: 17 Jul 2007, 15:00
Contact:

Re: Paint bucket not working

Post by Fabrice » 02 Nov 2017, 16:55

range = 174 : it seems pretty high to me.
also, make sure there are no gap, since your gap value is 0
Fabrice Debarge, Product Manager, TVPaint Team

User avatar
D.T. Nethery
Posts: 2077
Joined: 27 Sep 2006, 19:19

Re: Paint bucket not working

Post by D.T. Nethery » 02 Nov 2017, 18:42

I also suspect the Range is set too high.

You can use a high Range number , but you must have NO GAPS in your lines. (or if your line style intentionally has gaps or breaks in the line , then you must use the Gap Closer , or you can close off the gaps with a colored line (red, green , or blue) that will be colored the same color as the fill color using the "Include Borders" function in the Paintbucket tool , so after coloring the gap closing lines will be invisible . See here for an explanation:

viewtopic.php?t=9879#p91842


The tutorial below covers using the paintbucket set to a high range , but notice that he's working at high res. (4K res, with intended output to 2K) the drawings are very clean and do not have gaps (except a couple of places where he forgot to close off a line and he points out the mistake, which I think is actually very useful in a tutorial to see someone make a mistake and then point out the problem , and correct it as they are doing the tutorial . I think that makes the information sink in deeply and then I will tend to be less likely to make the same mistake in my own work.)

https://www.youtube.com/watch?v=Y5GBwEE6jgE

MAC OS 10.11.6 , Macbook Pro Retina 15-inch, Mid 2015,
2.5 GHz Intel Core i7, 16 GB Memory , TVPaint PRO 11.0.6, 64bit -
Wacom Cintiq 21 UX - Wacom Intuos Pro 5 - driver version 6.3.20-8

User avatar
Elodie
Site Admin
Posts: 13298
Joined: 06 Jan 2009, 09:53
Location: Metz

Re: Paint bucket not working

Post by Elodie » 03 Nov 2017, 04:22

I also suspect the Range is set too high
So did I, that's why I told her to reset the paint bucket :mrgreen:

However, even with such a high range value, I don't understand why it fills 90% of the image rather than 100%. And what is not filled makes no sense when we look at the lineart.

Great video Davd, btw, thanks for sharing ! We will post it on Facebook, so people with the Standard Edition can master the Paint bucket :)

However, I did not understand the purpose of painting the character in black first. I thought he would use it as a stencil, but finally it was useless. Or did I missed something because it's 5am ? :roll:
Questions or problems regarding the forum ? Please contact me by PM
Question regarding TVPaint or need a quotation ? Please contact me by email

User avatar
D.T. Nethery
Posts: 2077
Joined: 27 Sep 2006, 19:19

Re: Paint bucket not working

Post by D.T. Nethery » 03 Nov 2017, 13:45

Elodie wrote:
03 Nov 2017, 04:22
However, I did not understand the purpose of painting the character in black first. I thought he would use it as a stencil, but finally it was useless. Or did I missed something because it's 5am ? :roll:
Around the 5:51 mark [ https://youtu.be/Y5GBwEE6jgE?t=351 ] he explains how he uses the solid black silhouette layer . This is turned on to fill in any tiny gaps where color has not filled in all the way to the line , such as tight corners where two lines intersect , which is typically where gaps or holes will appear. The solid black layer underneath fills in those very small holes to make them the same color as the line art , which in this case is black, but if the line art was grey or red or some other color , the solid silhouette layer would be the same color as the line.
small holes-gaps_at_corners.png
Solid black layer fills in small holes.png
.
MAC OS 10.11.6 , Macbook Pro Retina 15-inch, Mid 2015,
2.5 GHz Intel Core i7, 16 GB Memory , TVPaint PRO 11.0.6, 64bit -
Wacom Cintiq 21 UX - Wacom Intuos Pro 5 - driver version 6.3.20-8

User avatar
D.T. Nethery
Posts: 2077
Joined: 27 Sep 2006, 19:19

Re: Paint bucket not working

Post by D.T. Nethery » 03 Nov 2017, 14:06

Elena C wrote:
02 Nov 2017, 16:26
I've tried using the rectangle fill tool and although it does the job, it thickens the lines that are not meant to be shape contour (like the hairs of my character). Please look at the attached images to see what I mean.
About the Filled Rectangle: I think this is probably also a case where you may have the Range set too high. Try it at Range = 24 , with Expand set to 1 .

What is your project resolution ? ( 1920 x 1080 ? 1280 x 720 ? or lower ? Better if you can work at higher resolution such as 1920 x 1080 OR even better if you work at maybe 150% - 200% over the intended output resolution , so if your intended output is 1920 x 1080 work at 2880 x 1620 (150%) or 3840 x 2160 (200%) , then when you output the final images scale down to 1920 x 1080 .)
Last edited by D.T. Nethery on 03 Nov 2017, 14:24, edited 1 time in total.
MAC OS 10.11.6 , Macbook Pro Retina 15-inch, Mid 2015,
2.5 GHz Intel Core i7, 16 GB Memory , TVPaint PRO 11.0.6, 64bit -
Wacom Cintiq 21 UX - Wacom Intuos Pro 5 - driver version 6.3.20-8

User avatar
Elodie
Site Admin
Posts: 13298
Joined: 06 Jan 2009, 09:53
Location: Metz

Re: Paint bucket not working

Post by Elodie » 03 Nov 2017, 14:15

The solid black layer underneath fills in those very small holes to make them the same color as the line art
Oh yes, thank you ^^
Questions or problems regarding the forum ? Please contact me by PM
Question regarding TVPaint or need a quotation ? Please contact me by email

Elena C
Posts: 6
Joined: 19 Aug 2017, 08:40

Re: Paint bucket not working

Post by Elena C » 03 Nov 2017, 14:33

Thank you so much everyone!!!

Post Reply

Who is online

Users browsing this forum: Bing [Bot], Google [Bot] and 22 guests