Bug: Annoying Drawing Lag when Switching Between Tools With Texture

Please use this part to report bugs & errors, ask questions & "How to..."
Post Reply
TheQuestionMark
Posts: 121
Joined: 26 Sep 2013, 12:01

Bug: Annoying Drawing Lag when Switching Between Tools With Texture

Post by TheQuestionMark » 23 Nov 2017, 02:24

There this annoying bug.

When I setup a hotkey for a tool that use texture. There is this drawing lags that slows you down when you draw. Everytime I switch between Full Eraser and Pencil Brush with Texture quickly, it lags when drawing. It's really annoying. Try pressing hotkey with Pencil Brush with Texture repeatedly while drawing and keep pressing the hotkey repeatedly. It freezes up when you draw.

I think the bug located when it re-toggles "ON" the texture when pressing the hotkey repeatedly. But when you set it up to 'turn off texture mode' it doesn't lag anymore.


--
It also delay lag when drawing switching between two hotkey. Eraser Off Texture, and Pencil Brush On Texture.
Last edited by TheQuestionMark on 24 Nov 2017, 00:01, edited 1 time in total.
Windows 10 64-Bit TvPaint Professional 11.0.8 (64-Bit)

User avatar
ini
Posts: 7
Joined: 14 Aug 2015, 17:47

Re: Bug: Annoying Drawing Lag when Switching Between Tool With Texture

Post by ini » 23 Nov 2017, 05:59

How about using the 'Hide Tools Preview' option in Preference>display tap?

User avatar
Fabrice
Posts: 9872
Joined: 17 Jul 2007, 15:00
Contact:

Re: Bug: Annoying Drawing Lag when Switching Between Tool With Texture

Post by Fabrice » 23 Nov 2017, 10:18

Can you record a short video ? That would help a lot to fix this.
Fabrice Debarge, Product Manager, TVPaint Team

TheQuestionMark
Posts: 121
Joined: 26 Sep 2013, 12:01

Re: Bug: Annoying Drawing Lag when Switching Between Tool With Texture

Post by TheQuestionMark » 23 Nov 2017, 15:23

Fabrice wrote:
23 Nov 2017, 10:18
Can you record a short video ? That would help a lot to fix this.
https://drive.google.com/open?id=1_bEUF ... ThxjWvjPlN

Here's the Video. Not sure how video can work when you can't see the keyboard. Three Lines drawn were draw in first without pressing the shortkey. After the three lines, I then press the key repeatedly when drawing. As you can see there's is an apparent lag when drawing. You can see the top left corner that the Texture Icon "Re-toggles On" when repeatedly pressing the shortkey when drawing. You can see the dots appear but no lines due to lagging issue when drawing.


If you were to draw fast between Pencil Brush Texture and Eraser, it lags like crazy.

ini wrote:
23 Nov 2017, 05:59
How about using the 'Hide Tools Preview' option in Preference>display tap?
Nope doesn't work unfortunately.
Windows 10 64-Bit TvPaint Professional 11.0.8 (64-Bit)

User avatar
Mike
Posts: 1001
Joined: 16 Feb 2006, 08:58

Re: Bug: Annoying Drawing Lag when Switching Between Tools With Texture

Post by Mike » 24 Nov 2017, 09:10

Do you have "LineSmoothing" activated ? Then can you test without it
TVPaint Team

TheQuestionMark
Posts: 121
Joined: 26 Sep 2013, 12:01

Re: Bug: Annoying Drawing Lag when Switching Between Tools With Texture

Post by TheQuestionMark » 24 Nov 2017, 09:52

Mike wrote:
24 Nov 2017, 09:10
Do you have "LineSmoothing" activated ? Then can you test without it
The Video is without Line Smoothing. I don't think Line Smoothing is a Factor especially when trying to toggle back from the eraser.
Windows 10 64-Bit TvPaint Professional 11.0.8 (64-Bit)

Post Reply