Audio plays back slightly too fast

Please use this part to report bugs & errors, ask questions & "How to..."
User avatar
melaphant3
Posts: 18
Joined: 23 May 2011, 07:12
Location: Australia
Contact:

Audio plays back slightly too fast

Post by melaphant3 » 04 Sep 2011, 09:40

Hey guys,

I'm having 'aaargh' problems. Any sounds I import plays back too fast and a little higher pitched than they should. I tested this with different bitrates (and different playback sample rates in TVPaint) and file formats but the problem always remains regardless of file format (wav or mp3 or aac). Re-exporting these sounds at different sample rates (44100 / 48000 / 22050) and putting them back in TVP seems to have no effect on the speed that it's played back.

I've kept the FPS in the project settings the same as the FPS in the remote control - if the remote control FPS is changed so it doesn't match the project, the sound doesn't just drop or raise in speed, but seems to 'glitch' and stutter instead.

I've seen other topics posted about similar problems, but their solutions haven't worked. Does anyone know what other sound settings can I play with or look out for? Any idea what I am doing wrong?

Some settings:
TVPaint version: Pro 9.5.18 on Mac OSX snow leopard
Project FPS: 24
Playback FPS: 24

I'd super duper appreciate any tips.
Sometimes I tumble : D
http://melaphantastic.tumblr.com/

User avatar
Paul Fierlinger
Posts: 7691
Joined: 03 May 2008, 12:05
Location: Pennsylvania USA
Contact:

Re: Audio plays back slightly too fast

Post by Paul Fierlinger » 04 Sep 2011, 13:28

What is the size of your project? Are you using Proxy and if so, what are your settings? Where are you playing back from; the Project Tab or Timeline Tab? Where did you load your track; in Project tab, or directly in the clip?
Paul
http://www.slocumfilm.com
Desktop PC Win10-Pro -64 bit OS; 32.0 GB RAM
Processor: i7-2600 CPU@3.40GHz
AMD FirePro V7900; Intuos4 Wacom tablet

User avatar
melaphant3
Posts: 18
Joined: 23 May 2011, 07:12
Location: Australia
Contact:

Re: Audio plays back slightly too fast

Post by melaphant3 » 04 Sep 2011, 15:24

Hi Paul, thanks for getting back to me.

No matter the size of the project the same problem persists - I've tried on practically blank projects (however the main project I'm currently working on is 405mb so far). I'm not entirely sure what a proxy is, but I don't think I'm using one - it's an independent student project all just on the one computer, no servers. I loaded the track under the 'master' tab on the timeline, and also tried the 'project > load sound' option. And I'm previewing the animation using the Remote Control buttons or scrubbing through the timeline.

I just tried an export test and worked out that only the preview isn't working, and it's not effecting the export.

cheers
Sometimes I tumble : D
http://melaphantastic.tumblr.com/

User avatar
Paul Fierlinger
Posts: 7691
Joined: 03 May 2008, 12:05
Location: Pennsylvania USA
Contact:

Re: Audio plays back slightly too fast

Post by Paul Fierlinger » 04 Sep 2011, 15:37

OK, I never had a Mac but I think it can't be that different in this case from the PC. Go to the main menu bar and look under windows to find "Preview Setiings". Open that panel and you'll see "Background Proxy Render and "Force Proxy Render". If they are selected, tic them off. Play with these settings a bit more to find the right setting which will stop your sound distortion. The Quality you might want to set to 50% or lower, if you end up with one of the Proxy settings ticked on. Let me know if this works for you.
Paul
http://www.slocumfilm.com
Desktop PC Win10-Pro -64 bit OS; 32.0 GB RAM
Processor: i7-2600 CPU@3.40GHz
AMD FirePro V7900; Intuos4 Wacom tablet

User avatar
melaphant3
Posts: 18
Joined: 23 May 2011, 07:12
Location: Australia
Contact:

Re: Audio plays back slightly too fast

Post by melaphant3 » 04 Sep 2011, 16:38

I had a play with those settings. The Proxy Renderers and Quality didn't make a difference to the remote control player. However when I increased the 'flip book' settings to 20 seconds, interestingly it did play it at the correct speed when I pressed 'W', yet the pitch was still unusually high. I suppose that's probably as good as it gets, and I don't mind using this method. It still puzzles me though.
Sometimes I tumble : D
http://melaphantastic.tumblr.com/

User avatar
Mads Juul
Posts: 3993
Joined: 02 May 2007, 19:18
Location: Viborg,Denmark
Contact:

Re: Audio plays back slightly too fast

Post by Mads Juul » 05 Sep 2011, 07:29

If I remember correct I have experienced the same on a mac, and I think there is a difference between mac/pc.
A solution could be to make sure all your sound files is in the same format 48000 Hz 16 bit mono for instance.
and then make sure under Edit<Ppreferences<Sound the sampling rate is set to 48000 Hz.

Do you have the latest version of quicktime, if I remember the version of quicktime also have an influence.
At a point I updated Quicktime and then the playback wasn't in sync and then it was later on a mac.

But i think this is a bug in TVpaint. In that sense TV Paint should play back correctly no matter what
-Mads
Mads Juul
Storyboard Artist
blog: http://mjstoryboard.blogspot.dk/
Mail: mjstoryboard@gmail .com

Windows 10, 64 bit i7-4790 CPU 4.00 Hz,32 GB RAM, With TVP Animation 11 Pro (11.0.2-64bits)
2 Monitors 1920X1080 pixels + 1 Wacom Cintiq 21UX 2

User avatar
Mads Juul
Posts: 3993
Joined: 02 May 2007, 19:18
Location: Viborg,Denmark
Contact:

Re: Audio plays back slightly too fast

Post by Mads Juul » 05 Sep 2011, 07:31

btw have you tried only to use mono tracks?
I know TVPaint had problems mono vs Stereo and was happier for mono at some point. Don't know if this is corrected
Mads Juul
Storyboard Artist
blog: http://mjstoryboard.blogspot.dk/
Mail: mjstoryboard@gmail .com

Windows 10, 64 bit i7-4790 CPU 4.00 Hz,32 GB RAM, With TVP Animation 11 Pro (11.0.2-64bits)
2 Monitors 1920X1080 pixels + 1 Wacom Cintiq 21UX 2

User avatar
Hervé
Site Admin
Posts: 3490
Joined: 08 Feb 2006, 17:00
Location: Metz France
Contact:

Re: Audio plays back slightly too fast

Post by Hervé » 05 Sep 2011, 12:12

It's a known bug in quicktime since OSX 10.6, which no longer convert frequencies in the audio load process.

You can convert manually the frequency of your audio files to 44800khz with some free softwares like audacity

We will try to find a way to fix the issue with quicktime.
Hervé ADAM, TVPaint Team

User avatar
D.T. Nethery
Posts: 2491
Joined: 27 Sep 2006, 19:19

Re: Audio plays back slightly too fast

Post by D.T. Nethery » 05 Sep 2011, 12:42

Hervé wrote:It's a know bug in quicktime since OSX 10.6, which no longer convert frequencies in the audio load process.

You can convert manually the frequency of your audio files to 44800khz
with some free softwares like audacity

We will try to find a way to fix the issue with quicktime.
I've used Audacity before and it's a very good software (and always nice to have something free !)

So is 44800 khz the ideal frequency for sound files in TVPaint ? Does mono vs. stereo make any difference for accurate playback in TVPaint ? (as Mads mentioned above)

User avatar
ematecki
Site Admin
Posts: 1979
Joined: 15 Feb 2006, 14:32

Re: Audio plays back slightly too fast

Post by ematecki » 05 Sep 2011, 13:40

The exact samplig rate you use has no effect.
The problem comes fron the conversion of sampling rates by quicktime.

So your audio files MUST have the SAME sampling rate as set in the preferences.
Choose one sampling rate and stay with it, at least until we find a work around this quicktime bug.

(BTW, it's 44.1 kHz for CD audio, or 48 kHz for "DAT" audio...)
You can choose your friends,
but you can't choose your family.

User avatar
melaphant3
Posts: 18
Joined: 23 May 2011, 07:12
Location: Australia
Contact:

Re: Audio plays back slightly too fast

Post by melaphant3 » 07 Sep 2011, 15:20

Sorry everyone for taking ages to get back.
I've been playing with the sounds a bit it the meantime - stereo/mono makes no difference.
Ah, everything is confusing. So is everyone saying the quicktime bug is something I can't get around? Or can I edit the quicktime settings to match (in which case I haven't a clue how to do so)? I've currently got the latest Quicktime 10.0 if that helps.

Also, thankyou for reminding me about Audacity. I've been looking for something like it recently and had forgotten its existence.
Thanks everyone for your help, too! Really appreciate it.
Sometimes I tumble : D
http://melaphantastic.tumblr.com/

User avatar
ematecki
Site Admin
Posts: 1979
Joined: 15 Feb 2006, 14:32

Re: Audio plays back slightly too fast

Post by ematecki » 07 Sep 2011, 15:24

I just described the workaround...

Convert all your audio files to the same sampling rate, set that sampling rate in TVP's preferences, and it should work.

Good luck.
You can choose your friends,
but you can't choose your family.

User avatar
melaphant3
Posts: 18
Joined: 23 May 2011, 07:12
Location: Australia
Contact:

Re: Audio plays back slightly too fast

Post by melaphant3 » 11 Sep 2011, 05:34

Hey Ematecki,

I tried your work around - exporting the same sound out of Audacity at 22050 / 44100 / 48000 and importing them into TVP projects with different sample rates. Unfortunately no combination of import sample rate and TVP sample rate will make the sounds play at the right speed - all the same slightly too high / fast. All 24fps in the project and in the remote control. Thanks for your suggestion, but alas it didn't work :( aww.
Sometimes I tumble : D
http://melaphantastic.tumblr.com/

User avatar
ematecki
Site Admin
Posts: 1979
Joined: 15 Feb 2006, 14:32

Re: Audio plays back slightly too fast

Post by ematecki » 12 Sep 2011, 07:43

If you have QT X , try to disable/uninstall it.

If not, that's really strange as it works for everybody else...
You can choose your friends,
but you can't choose your family.

User avatar
melaphant3
Posts: 18
Joined: 23 May 2011, 07:12
Location: Australia
Contact:

Re: Audio plays back slightly too fast

Post by melaphant3 » 13 Sep 2011, 07:27

Uninstalled QT X and now it works!!! Yaaaay!
Thankyou thankyou thankyou!
Sometimes I tumble : D
http://melaphantastic.tumblr.com/

Post Reply