QuickSave2 Button Set (updated version - July 14, 2016)

Share your custom panels, brushes, papers... (you need to be registered to read posts in this section)
Post Reply
Svengali
Posts: 1081
Joined: 28 Dec 2006, 10:08
Contact:

QuickSave2 Button Set (updated version - July 14, 2016)

Post by Svengali » 07 Jul 2016, 18:41

Here is the QuickSave2 Panel update which lets you directly save single image files - Display mode (include all visible layers) or Layer mode (only the current Layer). You can also directly load image to the current Clip/Layer/frame.
QuickSave2.jpg
Four Buttons for directly saving and loading the current Clip/Layer/Frame image to a designated folder of your choice. Here's what the four buttons do.

Set Path (do this first)
Lets you select a default path/folder, so the other buttons can save the current Display (includes all visible layers and opaque background) or the current Layer (with alpha mask, preserving transparency).

Save Display
Lets you save all visible Clip/layer/frames and opaque background into an auto-named, auto-incrementing file in the default path/folder. (default naming: TVP-Display00001.png or some incremental variation)

Save Layer
Lets you save the current Clip/layer/frame, visible or not, into an auto-named , auto-incrementing file in the default path/ folder. Alpha Masking of the layer image will preserve the transparency of the surrounding area. (default naming: TVP-Layer00001.png or some incremental variation) Updated to use NoPreMultiply for AlphaSaveMode - July 14, 2016

Load Image
Lets you load an Image to the current Clip/layer/frame. Loading a saved Display will have an opaque background. Loading a saved Layer will have a transparent background so that content from lower layers may show through. (default extension .png)]

If you have any problems (Mac PC or Linux) please post details and error-messages here, thanks! :D

Sven

EDIT: I've uploaded an updated version in which the AlphaSaveMode has been changed to NoPreMultiply (avoids fringing).
Please down load again and install over old version.
You do not have the required permissions to view the files attached to this post.
Last edited by Svengali on 14 Jul 2016, 13:28, edited 1 time in total.
Desktop: tvp Pro 11.0.6-64bit, Win8.1 - 24GB ram -2TB HHD - 256GB SSD - intuos4 - d.ver.6.3.15-3
Android Tablet: release 11, Samsung Galaxy Note10.1 - 32GB internal - microSD 32GB

User avatar
NathanOtano
Posts: 852
Joined: 01 Apr 2014, 07:07
Location: Paris, France
Contact:

Re: QuickSave2 Button Set

Post by NathanOtano » 08 Jul 2016, 10:31

Nice Thanks :)
Storyboard, animation and design work : http://nathanotano.tumblr.com/
As I'm highly interested in animation workflows, I'm open to scripting new TVP functions for individuals and studios. Please don't hesitate to contact me!

User avatar
Soom
Posts: 692
Joined: 25 Jul 2011, 16:25
Location: World
Contact:

Re: QuickSave2 Button Set (updated version - July 14, 2016)

Post by Soom » 05 Dec 2016, 15:05

Hi Sven
I have a problem with setting the path for this script - it doesn't let me save a path without typing the file name. I have it set to "nofile.png" but for some reason this setting overrides the file name I give during an export. So basically no matter what - it will always save to "nofile.png" overwriting any existing file. Which means I have to go and rename the file each time after export.
Any way to fix that?
I'm on MacBook Pro, Yosemite, TVP 11
(it doesn't happen on Windows)
thanks

update: I just tried to leave the default name and what I got was even more bizarre: when I save it with the default naming - that's the file name I get: nofile.pTVP1-Layer00001.png
At home: MacBook Pro, Os 10.10.3 (2.2 GHz Intel Quad-Core i7, 16 GB RAM), Cintiq 21", TVP Std 11.0.3
At work: PC, Windows 7, Cintiq 22", TVP Std 11.0.3

Svengali
Posts: 1081
Joined: 28 Dec 2006, 10:08
Contact:

Re: QuickSave2 Button Set (updated version - July 14, 2016)

Post by Svengali » 05 Dec 2016, 23:07

Soom wrote:Hi Sven
I have a problem with setting the path for this script - it doesn't let me save a path without typing the file name. I have it set to "nofile.png" but for some reason this setting overrides the file name I give during an export. So basically no matter what - it will always save to "nofile.png" overwriting any existing file. Which means I have to go and rename the file each time after export.
Any way to fix that?
I'm on MacBook Pro, Yosemite, TVP 11
(it doesn't happen on Windows)
thanks

update: I just tried to leave the default name and what I got was even more bizarre: when I save it with the default naming - that's the file name I get: nofile.pTVP1-Layer00001.png
Sorry, I don't have access to any Mac system so I can't directly check it out.
If you have access to more than one Mac system does it happen on all?
Did this just start happening, if so, what changed? Upgrade of OS?
On the other hand, did you just try out the QuickSave button/scripts and found the problem first time you used it?
Could you please post the complete PATH that you are entering (selecting) using the SetPath button? If I can see that, maybe I can tell what is causing the failure (which maybe a parsing problem.)

Thanks, Sven
Desktop: tvp Pro 11.0.6-64bit, Win8.1 - 24GB ram -2TB HHD - 256GB SSD - intuos4 - d.ver.6.3.15-3
Android Tablet: release 11, Samsung Galaxy Note10.1 - 32GB internal - microSD 32GB

User avatar
Soom
Posts: 692
Joined: 25 Jul 2011, 16:25
Location: World
Contact:

Re: QuickSave2 Button Set (updated version - July 14, 2016)

Post by Soom » 06 Dec 2016, 00:30

Hi.
I was using this script for a while on both computers, that's why I can't remember exactly when did things go wrong. It surely did work well before some recent time. There were a few recent updates on the system - Security update 2016-006 on November 4th, and something XProtectPlistConfigData, whatever that is - several of those.
The full path is /Users/Danas/Pictures/from_TVP/nofile.png

hope that helps...
At home: MacBook Pro, Os 10.10.3 (2.2 GHz Intel Quad-Core i7, 16 GB RAM), Cintiq 21", TVP Std 11.0.3
At work: PC, Windows 7, Cintiq 22", TVP Std 11.0.3

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests