Documentation

Exporting you custom settings

You have the possibility to export some of your configuration options and custom presets when upgrading from TVPaint Standard Edition to TVPaint Professional Edition.

You can export and import the following elements to preserve your current workflow as much as possible when upgrading:

-Keyboard shortcuts (lesson 1)
-Custom mixed colors (lesson 2)
-Custom palettes (lesson 2)
-Color groups (lesson 4)
-Layer presets (lesson 4)
-Custom panels (lesson 11)
-FX stacks (lesson 12)

Here-below is a quick recap on how to export those different settings. You can also refer to the aforementioned lessons in order to gain more in-depth knowledge regarding these custom elements.

Keyboard shortcuts:

It is possible for you to export your custom keyboard shortcuts.

In order to do so, simply open the keyboard shortcuts by clicking on the Edit menu and selecting the Shortcuts option. You can also open it by pressing the [Ctrl+K] keys. Then, click on the File menu and select the Save KeyMap option to save your current keyboard shortcuts.



The resulting .cfg file can then be imported in TVPaint Animation Professional Edition by opening the same keyboard shortcuts window and then selecting the Load KeyMap option.

Custom color mixes and palettes:

You can save your color mixes as a .dip file. To do so, simply right click on the color mix you wish to export and click on File to make the Export Mixer option appear. Simply use the Import Mixer option to import a color mix.

Custom palettes can be exported as a .pal file to be imported later on. You can achieve this by right clicking on the palette you wish to save, clicking on the File submenu and choosing the Save Palette option. The Load Palette option will allow you to import a custom palette.

Color groups:

You can also export your custom layer color groups by clicking on the icon, clicking on Edit and then selecting the Options menu. You’ll then have the possibility to save or to import a color group.

Layer presets:

You can also export all your custom layer presets using the Layer Preset Manager. The resulting .ini file can be imported into TVPaint Animation Professional Edition. You just have to open the Layer Preset Manager by clicking on the New layer menu and then selecting the Open New Layer Presets option. You will then be able to export or import your custom layer presets.

Custom panels:

You can export your custom panels by right clicking on them and then selecting the This Panel list and the Export as TVPX option. You’ll be able to import the resulting .tvpx file by clicking on the Custom Panels menu and selecting the Load a Custom Panel option. You can learn more about custom panels in lesson 11.

FX stacks:

FX stacks can also be saved and imported. Open your FX stack and click on the Preset menu to export it as a .bin file or to import one.