Documentation

The Blur > Motion Blur effect

The purpose of this effect is to apply a blur involved by some fast movements in an image or an animation. The animator can define a flow, based on a vector field, that the pixels of the image will follow.

This effect comprises four tabs :

The Edit tab



Source Image

- The first button allows you to set the size of the vector field. More exactly it allows you to set the number of vectors that you will use on both the horizontal and vertical axis.
Once you have chosen the size, you can edit the current vector field itself. To do so, display the H.U.D and draw directly on the screen (to be exact : on the H.U.D) with the purple circle, as shown below.
If you have a picture behind the vector field, you should see the render of the distortion.


Vector fieldModified image

The left mouse button allows to increase the tension of the vectors in a chosen direction.
The right mouse button allows to decrease the tension of the vectors in a chosen direction.

The red points are the source points of your vectors, they can't be moved.
The green points are the destination points of your vectors.
The blue segments are the vectors themselves.


For a given picture in your timeline, modifying the vector field creates an animation key.
If more than one animation key is created in the timeline, it means that your vector field and thus the distortion will evolve in time.


- The Reset Current Key button resets the vector field of the current picture in the timeline. If this picture does not have an animation key, a new one will be automatically created.

- The button allows you to modify all the vectors of the field in only one operation. This tool is perfect if you need to distort, move or pivot an image entirely.



The more vectors you will use, the more time you will need to render the effect.

- The button allows to change the parameters of your H.U.D brush (i.e : the purple circle)
Like the common tools (airbrush, etc ...) that you use to draw, you can set its profile, size and also power.

Let's admit that we will always choose the direction opposite when editing our vector field (i.e : the red arrow) :

The pictures below shows the impact of the different settings at your disposal.



The Selection tab



In this tab, you can select the vectors of the field that you want to edit via the previously discussed tools.
By default, all the vectors are selected. The two buttons Select All and Clear Selection allows you to reset the selections.

As in the main panel, you can use one of the three selections icons : Square, Freehand or Circle selection.

When doing a selection, if a vector is selected, it appears in yellow instead of blue. (if you want to select a vector, just select its source)

If a vector source is not selected, its H.U.D color becomes lighter.
The tools available in the Edit menu will only apply on the selected vectors.


The circle selection use the same parameters as the H.U.D brush (the purple circle) so you can select your vectors by “drawing on the H.U.D”
It allows you to have source points only selected in part and thus to have nice effects when editing the vectors.

Note that if you reset the size of the vector field, all the settings that you have done (vectors, animation keys, selections, ...) will be lost.

The Render tab

The Render tab allows you to choose the distortion mode of the image borders

The example below illustrates the three modes at your disposal.



Source ImageVector Field


None Border Mode


Mirror Border Mode


Loop Border Mode

The Display tab

The three buttons: Show Source, Show Destination and Show Vectors allow you to select exactly what you want to see on the H.U.D : the red source points and/or the green destination points and/or the blue vectors.

The button Show Only Selection allows to see only the vectors located inside the current selection.