Documentation

The Distortion > Optical Flow effect

The purpose of this effect is also to distort the current image or animation, but in a different way than the Distortion > Warp Grid effect. It uses a vector field instead of a grid. This vector field defines a flow that will be followed by the pixels of the current image.

The parameters of this effect are really close to the Blur > Motion Blur effect in Lesson 13. They have the same functionality, the only difference between the two effects, is that the rendered image is different. That's why they are in different sections.

This effect comprises four tabs.

The Edit tab



* The first button allows you to set the size of the vector field. More exactly it allows you to set the number of vector that you will use on both the horizontal and vertical axis.
Once you have chosen the size, you can edit the current vector field itself.
To do so, display the H.U.D and draw directly on the screen (to be exact : on the H.U.D) with the purple circle, as shown below.
If you have a picture behind the vector field, you should see the render of the distortion.


Vector fieldModified image

The left mouse button allows you to increase the tension of the vectors in a chosen direction.
The right mouse button allows you to decrease the tension of the vectors in a chosen direction.

The red points are the source points of your vectors, (they can't be moved)
The green points are the destination points your vectors,
The blue segments are the vectors themselves.


For a given picture in your timeline, modifying the vector field creates an animation key.
If more than one animation key is created in the timeline, it means that your vector field and thus the distortion will evolve in time.


* The Reset Current Key button reset the vector field of the current picture in the timeline. If this picture does not have an animation key, a new one will be automatically created.

* The button allows you to modify all the vectors of the field in only one operation. This tool is perfect if you need to distort, move or pivot an image entirely.



The more vectors you will use, the more time you will need to render the effect.

* The button allows to change the parameters of your H.U.D brush (i.e : the purple circle)
Like the common tools (airbrush, etc ...) that you use to draw, you can set its profile, size and also power.

Let's admit that we will always choose the direction opposite when editing our vector field (i.e : the red arrow) :

The pictures below shows the impact of the different settings at your disposal.





The last button that looks like 2 crossing arrows allow you to manage a random distortion of the image. This option has the ability to move pixels from your image dimly or strongly. Combined with another effect, like Stylize > Noise, you will have the opportunity to create a convincing faux-fixe.



• The parameter Seed is a value proposed by default and does not need to be changed.
• The parameter Length defines the distance between the destination points (green) and the source points (red). The bigger this value is, the more the image will be shaked (and conversely).
• The parameter Variance allows to increase the strength of the move, following the Length value. The bigger this value, the stronger and the more powerful the tremor will be (and conversely).

The Selection tab



* In this tab, you can select the vectors of the field that you want to edit via the previously discussed tools.
By default, all the vectors are selected. The two buttons Select All and Clear Selection allow you to reset the selections.

As in the main panel, you can use one of the three selections icons : Square, Freehand or Circle selection.

When doing a selection, if a vector is selected, it appears in yellow instead of blue. (if you want to select a vector, just select its source)

If a vector source is not selected, its H.U.D color becomes lighter.
The tools available in the Edit menu will only apply on the selected vectors.


The circle selection use the same parameters as the H.U.D brush (the purple circle) so you can select your vectors by “drawing on the H.U.D”
It allows you to have source points only selected in part and thus to have nice effects when editing the vectors.

Note that if you reset the size of the vector field, all the settings that you have done (vectors, animation keys, selections, ...) will be lost.

The Render tab

The Render tab allows you to choose :
* The calculation algorithm of the distortions (Blackman or by default)
* The distortion mode of the image borders (the example below illustrates the three modes at your disposal.)



Source ImageVector Field


None Image Mode


Mirror Image Mode


Loop Image Mode

The Display tab

The three buttons: Show Source, Show Destination and Show Vector allow you to select exactly what you want to see on the H.U.D : the red source points and/or the green destination points and/or the blue vectors.

The button Show Only Selection allows to see only the vectors located inside the current selection.