Documentation

Export files

Saving a project in TVPaint Animation format with all associated layers may require a considerable amount of storage capacity.

Even if it contains specific data relative to your project (opacity, layers, etc…), the TVP format is not a practical solution if you want to share it with your friends at parties or on a website. Use of the dependencies function will render your project smaller, but it is not more practical in the aforementioned cases.

The option File > Export project to... is used to convert your project into a format of your choice: animated GIF, AVI or QuickTime file, numbered frames sequence, etc. You will find this very practical as you are able to save your work in smaller files.

This option is present in the File main menu. Once selected, the following panel appears:



Its layout should be familiar to you. You may choose to export an image, an image sequence, a video, keep the layers or a custom brush (possibly animated). You will see 4 different tabs : Project : Display, Clip : Display, Clip : Layers structure and Custom Brush : Display. Each tab will be discussed in that lesson, but first at all, we will see the first part of the export panel, identical from a tab to another.

* The first section of the panel contains several options:

- The Browse button and an associated text field are used to enter the name and location of the file to be exported.

- As allows to choose the kind of export you want :
Single image (save the image visible in the right section of the panel only),
Sequence (save, frame per frame, the images located between the Mark in and Mark out points-. By default, the images are numbered as follows: file_name_1, file_name_2, … … … file_name_123, … Sequence becomes Animation when exporting in a video format.

Including a "0" in your file name may help with numbering your images. For example if the first file name is "dessin_000", the images will have the names dessin_001.jpg, dessin_002.jpg, … …dessin_354.jpg…

Animation is used to save all the frames between the Mark in and Mark out points in a single file and is available for some file formats (deep, gif, quicktime, fli, avi).

- Export and Cancel respectively export your animation or cancel (and so, close the export panel). But before exporting anything, we will study the options from the different tabs.

Project and Clip tabs :

As explained in lesson 8, the difference between these two tabs is simple : the first tab lets you export your entire current project (scenes and clips) whereas the second tab only exports the current clip.

* The second section deals with the export file formats:
TVPaint Animation allows you to export your projects in a wide variety of formats: DIP, AVI, GIF, BMP, QUICKTIME, DPX, FLI, PNG, PCX, SUNRASTER, PSD, TGA, JPG, ILBM, TIFF, and you can add these formats for TVPaint Animation: FLYER CLIP, D1 RTV, CINEON, SGI, SOFTIMAGE, VPB.

When the export file format imposes the choice and setting of a video and audio codec, click on the Config button to display the corresponding settings panel.

The codecs present in the popup menus and their configuration options are those installed in your operating system.

In order to save a TVPaint Animation project in DVD format, you must have a MPEG-2 encoder codec installed on your computer.

When required, and depending on the various formats of export, you may need to set the following option parameters:

- Mode : you may choose to export your work in the form of images or a video with a limited palette (8 bits=256 colors), a large palette (24 bits=16.777.216 colors), a palette which takes into account the pixel transparency: 32 bits, a palette with no color data, but only pixel transparency (a mask).

- The palette : in the case of a limited color palette, you may choose to use a gray scale palette, the user define located in the Bin tab of the palette panel, a global quantized palette to be used for all frames of your footage or animation, or a local quantized palette which is modified for each frame of an animation.

- The number of colors : you may also choose a precise number of colors between 2 and 256 (to do this you must first choose one of the two quantized palettes).

- Dither : the Dither button is used to disperse the pixels of your animation in order to simulate use of a palette with a lot more colors (technically referred to as «Floyd-Steinberg dithering»).

- Alpha : options relative to the Alpha function were discussed in the Load an image or animation chapter.

* The third section of this panel manages the restrictions and attributes imposed on a file to be exported (width, height, frame rate, pixel aspect ratio, field), compared with the original attributes (chosen when you created your project).

* The last section allows you to choose some behaviors, following the options you chose in the third and second section.
- The Background button, when checked, renders all the pixels of your images opaque using the background selected (color, check or none) which is placed behind the transparent pixels of your images.
- The Pixel Aspect Ratio button is used to correct the pixel aspect ratio of the images to be exported in accordance with the setting made in the fourth section.
- The Stretch to frame rate button, when checked, imposes a previously selected frame rate on the file to be exported while retaining the original duration.
- If the aforementioned button is checked, the Time interpolation button allows you to decide whether the frame rate (or fields) correction should be carried out by interpolation (smoothing) or duplication (or deleting as the case may be).
- The Slate button adds a black border around the content with the current frame, the name of the project and clip, and the date :

Layer Tab :

* Old TVPaint format :
This format is useful for persons who work with the current version of TVPaint Animation and a version older than the 9.5 version (released in September 2009), using the .TVP format (and not the current .TVPP).

You will obtain a file equal to the current clip. If you didn't know or used these old versions, do not care about this export.

* .PSD format :
If you want to export a project in .PSD from the Project or Clip tabs, you will export one image (or an image sequence) with all the layers merged, without transparency.

If you want to export your project with layers, you will need the options of the Layer tab. Two modes are available :
- Single image : all layers and all images that compose your project will be in only one file. Each element will be save as a layer and transparency will be preserved.
- Sequence : each image will be save in a .PSD file. If that image is originally composed of several layers, the .PSD file will keep all the layers. Transparency is also preserved.

* .CSV format :
This format is really useful for people working on several software and who quickly need an xsheet.

The .CSV format generates a .CSV file (readable with Open Office or Microsoft Excel) and an image folder. Those images are in fact the first image of each instance (the instance meaning is explained lesson 6), from each layer. Each image has a name and a number sequel (do not change them !). Combined with the .CSV file, now you are able to know in which order those images does appear, exactly like a traditional xsheet.

Custom brush tab :

Export's options are the same than the Project tab. As you guess, this option allows you to export directly the custom brush you are currently using. This option is really interesting, in particular if you want to gain time (it is faster to cut a custom brush and export it, than cropping an image and then, export it).

You want to explain to someone how to use a panel ? Hold the said panel (as if you wanted to move it) and press [G] on your keyboard. If you go on your drawing space : surprise ! Your panel is now a custom brush !

Once all the options are set for the current project in the export project panel, they will be linked to the current project. So, each time the export project panel will be opened, all the parameters will be filled by the ones set by the user the last time he exported a file with this project.

Video tutorial: Export a project

This tutorial will show you how to export your animations: