TVP v10 freezes when 'grab tool'

Please use this part to report bugs & errors, ask questions & "How to..."
BenEcosse
Posts: 162
Joined: 08 Dec 2008, 23:13

TVP v10 freezes when 'grab tool'

Post by BenEcosse » 04 Jul 2012, 15:33

I keep having an issue when I try and right click on my brushes tool bar and select 'grab current tool' to save my anim brush.
TVP v10.0.5 freezes and I have to abort the programme -this happens every time now.
Last edited by BenEcosse on 05 May 2016, 11:35, edited 2 times in total.

User avatar
Paul Fierlinger
Posts: 7716
Joined: 03 May 2008, 12:05
Location: Pennsylvania USA
Contact:

Re: TVP v10 freezes when 'grab tool'

Post by Paul Fierlinger » 04 Jul 2012, 16:33

I have no idea why TVP freezes on you but as a better workaround which will let you actually save your brush, try using the command "add action" and go from there. Does this also freeze TVP on you?
Paul
http://www.slocumfilm.com
Desktop PC Win10-Pro -64 bit OS; 32.0 GB RAM
Processor: i7-2600 CPU@3.40GHz
AMD FirePro V7900; Intuos4 Wacom tablet

User avatar
Eric Scholl
Posts: 1303
Joined: 04 Apr 2011, 14:40

Re: TVP v10 freezes when 'grab tool'

Post by Eric Scholl » 05 Jul 2012, 06:53

It doesn't freeze here, can you update your software, please ? Because the last version is the 10.0.7.

Maybe is it only on Windows, because here I am on Linux.

BenEcosse
Posts: 162
Joined: 08 Dec 2008, 23:13

Re: TVP v10 freezes when 'grab tool'

Post by BenEcosse » 05 Jul 2012, 10:51

I've updated to 10.0.7 but the issue still persists.
Last edited by BenEcosse on 05 May 2016, 11:35, edited 1 time in total.

User avatar
Paul Fierlinger
Posts: 7716
Joined: 03 May 2008, 12:05
Location: Pennsylvania USA
Contact:

Re: TVP v10 freezes when 'grab tool'

Post by Paul Fierlinger » 05 Jul 2012, 10:57

Sorry, I completely overlooked "animbrush", so I just tried it and I didn't get a freeze.
Paul
http://www.slocumfilm.com
Desktop PC Win10-Pro -64 bit OS; 32.0 GB RAM
Processor: i7-2600 CPU@3.40GHz
AMD FirePro V7900; Intuos4 Wacom tablet

BenEcosse
Posts: 162
Joined: 08 Dec 2008, 23:13

Re: TVP v10 freezes when 'grab tool'

Post by BenEcosse » 05 Jul 2012, 11:22

It's only when I use TVP10.
Last edited by BenEcosse on 05 May 2016, 11:45, edited 1 time in total.

Elodie
Posts: 13913
Joined: 06 Jan 2009, 09:53
Location: Metz

Re: TVP v10 freezes when 'grab tool'

Post by Elodie » 05 Jul 2012, 11:29

But Ben, have you updated your TVPaint ?

BenEcosse
Posts: 162
Joined: 08 Dec 2008, 23:13

Re: TVP v10 freezes when 'grab tool'

Post by BenEcosse » 05 Jul 2012, 11:47

yes
Last edited by BenEcosse on 05 May 2016, 11:36, edited 1 time in total.

BenEcosse
Posts: 162
Joined: 08 Dec 2008, 23:13

Re: TVP v10 freezes when 'grab tool'

Post by BenEcosse » 05 Jul 2012, 13:06

I took off 'sub pixel' tablet option in preferences and now I can save my the animBrush ok

I found my old post. viewtopic.php?f=10&t=3091" onclick="window.open(this.href);return false;
Last edited by BenEcosse on 05 May 2016, 11:36, edited 1 time in total.

User avatar
lemec
Posts: 1676
Joined: 19 Feb 2006, 08:54
Location: Toronto, Ontario, Canada
Contact:

Re: TVP v10 freezes when 'grab tool'

Post by lemec » 06 Jul 2012, 04:06

This is really strange. The sub pixel option lets you have sub-pixel accuracy from your tablet. This means that line drawing is a lot smoother when using thin brushes while zoomed out. It shouldn't have any effect on the crashing when saving animated custom brushes, but eeh.

Also, I'm using x86 so I probably cannot repro the crash.
(Win7x64, TVP Pro 11 32-bit)

BenEcosse
Posts: 162
Joined: 08 Dec 2008, 23:13

Re: TVP v10 freezes when 'grab tool'

Post by BenEcosse » 06 Jul 2012, 15:37

ok
Last edited by BenEcosse on 05 May 2016, 11:37, edited 1 time in total.

User avatar
lemec
Posts: 1676
Joined: 19 Feb 2006, 08:54
Location: Toronto, Ontario, Canada
Contact:

Re: TVP v10 freezes when 'grab tool'

Post by lemec » 06 Jul 2012, 18:31

Hm. Try these settings. I don't use any of the other options besides Optimize and Display, which I turn on and off as needed if I need to capture multiple layers.
Attachments
cutBrushSettings.jpg
cutBrushSettings.jpg (5.57 KiB) Viewed 13525 times
(Win7x64, TVP Pro 11 32-bit)

BenEcosse
Posts: 162
Joined: 08 Dec 2008, 23:13

Re: TVP v10 freezes when 'grab tool'

Post by BenEcosse » 06 Jul 2012, 21:26

Thanks Lemec.
Last edited by BenEcosse on 05 May 2016, 11:38, edited 1 time in total.

User avatar
lemec
Posts: 1676
Joined: 19 Feb 2006, 08:54
Location: Toronto, Ontario, Canada
Contact:

Re: TVP v10 freezes when 'grab tool'

Post by lemec » 07 Jul 2012, 03:46

Hm. when you cut out an animated brush, there's a prompt that says: "Do you want to cut out an Animbrush?" It's often easy to miss this prompt, especially if you're using a dual-display system and the prompt is appearing on a display that you aren't looking at.

Maybe it's freezing because it's waiting for you to hit the OK button.
(Win7x64, TVP Pro 11 32-bit)

BenEcosse
Posts: 162
Joined: 08 Dec 2008, 23:13

Re: TVP v10 freezes when 'grab tool'

Post by BenEcosse » 07 Jul 2012, 10:38

The issue is something to do with the fact that when I use the right click function on my pen with sub pixel enabled you have to drag the pen at the same time
Last edited by BenEcosse on 05 May 2016, 11:38, edited 1 time in total.

Post Reply