MacOS security update stops TVPaint working Topic is solved

Please use this part to report bugs & errors, ask questions & "How to..."
Post Reply
User avatar
Catriona
Posts: 56
Joined: 10 Apr 2018, 09:34
Location: The Netherlands
Contact:

MacOS security update stops TVPaint working

Post by Catriona » 29 Jul 2020, 09:08

I updated my OS yesterday with the latest security update and then it prevented the security driver of TVPaint from opening it up. I managed to fix it with the usual settings by clicking allow, but it won't let me this morning. I click Allow and nothing happens, and I've made a few attempts and restarts already. Help!
Screen Shot 2020-07-29 at 09.27.18.png
Screen Shot 2020-07-29 at 09.27.59.png
Screen Shot 2020-07-29 at 09.27.59.png (60.73 KiB) Viewed 3651 times

User avatar
Catriona
Posts: 56
Joined: 10 Apr 2018, 09:34
Location: The Netherlands
Contact:

Re: MacOS security update stops TVPaint working

Post by Catriona » 29 Jul 2020, 09:43

I have just tried to do the whole reinstall procedure as outlined here:

https://www.tvpaint.com/doc/tvpaint-ani ... l-register

but have ended up with exactly the same problem. I have work to do and am exploding with stress!

User avatar
Dean
Site Admin
Posts: 326
Joined: 28 May 2018, 09:07

Re: MacOS security update stops TVPaint working

Post by Dean » 29 Jul 2020, 10:07

Hello Catriona,
No need to worry, High Sierra is simly the worst in terms of security paranoia.

You have to be using a regular mouse to click on Allow, not a tablet stylus and sometimes even your mouse isn't allowed to click, this is really something else.

The alternative solution is to "click" on the button using the keyboard:
https://discussions.apple.com/docs/DOC-13013

Please note that your Mac might need a reboot before the trick works.
-Sales and Support-
Probably a vampire

User avatar
Catriona
Posts: 56
Joined: 10 Apr 2018, 09:34
Location: The Netherlands
Contact:

Re: MacOS security update stops TVPaint working

Post by Catriona » 29 Jul 2020, 10:26

Thank you Dean for helping me out! I still don't actually know what fixed it but I'm very happy it is working.

Post Reply